Skip to main content

PT100 Amp Board with Ultimaker 1.5.7 pcb wiring

Attempting to wire this up, it’s not working as I’ve got it (into the temp sensor 1 slot). Can someone please just tell me how this is supposed to be wired so I can stop effing around with it and get my printer running again???

Update (02/05/2019) In Response to Dan’s first answer-

Well, i’ve done all that and more in the past 11 days, and something is missing. I’m not sure if it’s missing from your instructions, though that’s my guess, or somewhere else. I currently have the PT100 installed in my hot end (A V6 gold with a copper-plated Volcano block, all from you guys, mind you), wired into the 2 pins on the amp board (I assume that which wire to which lead is immaterial), then the three pin is 5v to 5v, neutral to ground, signal directly to the Analog 3 pin on the Arduino. Firmware: been through about 20 times double checking and trying different stuff, different pins, etc. Tried 3 different user temp tables, one was the table from the previous thermistor that came with the V6, and should have worked according to your instructions, and twice (at least) with variations of the PT100 tables i’ve found. So, at this point, I think a little help from you guys to get your products up and working would be lovely.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

I got the E3D Pt100 temp sensor and amp working with my Prusa MK3, but it took some doing to install and debug it. I had to piece together a number of disparate pieces of information. Some tips.

0) Check wiring and make sure you are getting +5 on the board. Make sure FW build is modified for sensor and sensor signal is going into pin that FW is expecting. Sounds like you did all this. Not trying to insult your intelligence.

1) PT100 sensor. First check the unattached PT100 sensor. It should be about 100 ohms at room temp. There is a nice blog on how these sensors work (the “PT100” is an industry standard). https://blog.beamex.com/pt100-temperatur... About 3/4 down the way on the blog there is a figure of sensor resistance vs temp. Check several temps. Then you can determine if the sensor is faulty or not.

2) Installation. Be careful of tightening the PT100 cartridge too much. Turn screw to touch sensor, than additional 1/8 turn, NO MORE. The cartridge is easily crushed/damaged.

3) Open leads. If your temp reads the max range and does not vary, you have likely have an open circuit between the sensor and the amp, or the PT100 cartridge

4) After item (1) is good, check amplifier signal out. On the wiki E3D PT100 Amplifier Documentation there is a table of amplifier voltage out vs temperature “Output Characteristics”

Hope this helps.

I had mine working for awhile, then one of the leads broke loose. Read 999C. Installed a new one and it now seems to be reading a constant 70C too high, so I am back to step (1) above to try to determine if the amp or sensor.

Was this answer helpful?

Score 1

Comments:

I found an online PT100 resistance calculator

http://www.southerntemp.co.uk/reference/...

by

Thanks for the info, but I'm done screwing around with products that the company selling them can't properly support. Hopefully your answer will halp someone else, but the fact that you don't have yours fully operational yet tells me that I'll just waste even more time that I can't afford to lose. I will never buy another product from this company again.

by

Add a comment

Hi Aaron,


Unfortunately we do not have specific connection guides for specific boards, I would suggest looking up some pin out diagrams for your specific board in order to ascertain the correct connection points. https://reprap.org/wiki/Ultimaker%27s_v1...

Other wise as long as your printer board follows the typical Arduino Mega architecture then you should follow this PT100 connection guide, E3D PT100 Amplifier Documentation .

It may not be for the exact same board but the instructions should still be applicable.

Was this answer helpful?

Score 0

Comments:

And just so you don't think I'm singling you out, I have conversations going with both Ultimaker and Boxzy to cover my bases. It's possible that something is faulty here, as well, and I need to find out if that is the case and what it is so it can be replaced

by

Add a comment

Add your answer

aaronV will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 6

Past 30 Days: 13

All Time: 209